Bluefish: The Definitive Guide

Table of Contents

1. About this Manual
2. What is Bluefish?
2.1. History of Bluefish
2.2. Main Features of Bluefish
2.3. How Stable is Bluefish?
2.4. Contact Us
1. Getting and Installing Bluefish
I. Getting Bluefish
1. Choosing a Version
1.1. How and When Updates are Released
1.2. Operating Systems Supported by Bluefish
2. Latest Stable Version
3. Latest Snapshot Version
4. Latest Developmental Version
II. Installing Bluefish
1. Requirements
2. Quick Standard Installation
3. System Specific Installation Issues
4. Installing a Bluefish Source Distribution
4.1. Quick Installation Overview
4.2. Installing from Development Source Tree
4.3. Problems Compiling?
5. Configure Options
5.1. Standard configuration flags
5.2. Flags personal to bluefish
6. Installing a Binary Distribution
7. Post-installation Setup
2. Using Bluefish
III. Starting Bluefish
1. Launching Bluefish
2. Command line options
IV. The user interface
1. Editing Area
2. Menus and Tool Bars
3. Side Panel
4. Status Bar
5. Help Menu
V. Working with files and folders
1. Creating files
2. Managing directories
3. Opening files
4. Saving files
5. Renaming files
6. Deleting files
7. Closing files
8. Inserting files
9. Editing
9.1. Undo and Redo
9.2. Cut, Copy, and Paste
9.3. Input methods
10. Basic Find and Replace
10.1. Searching for a word within a whole document
10.2. Setting limits to the search scope
10.3. Case sensitive search
10.4. Overlapping searches
10.5. Retrieving previous search strings
10.6. More on find
10.7. Replacing features
10.8. Retrieving previous replace strings
10.9. Changing letter case when replacing
10.10. Choosing strings to replace
10.11. More on replace
11. File types
11.1. Syntax highlighting
12. More on files
12.1. Remote files
12.2. Character encoding
12.3. Open advanced
VI. Navigation and Managing documents
1. Navigating through a document
2. Navigating through many documents
3. Projects
4.1. Generating several bookmarks at once
5. Find and Replace
5.1. Find Again
5.2. Find from Selection
5.3. Find and Replace Using Regular Expressions
VII. More than a Text Editor
1. Indenting
2. Auto tag closing
3. Spell checker
4. Function reference
5.1. Special find and replace features
5.2. Thumbnail generation
6. Customizing the Quick bar
7. Custom menu
7.1. Adding a custom menu dialog
7.2. Adding a custom replace dialog
8. External programs, filters
8.1. Customizing browsers
8.2. Customizing Commands menu
8.3. Customizing Ouputbox menu
VIII. Customising Bluefish
1. Modifying shortcut keys
2. Showing hidden files and folders
3. Showing backup files
4. Editor appearance
5. Customizing the bookmarks path
6. Customizing the html tags style
7. Changing the author meta tag on the fly
8. Customizing files handling and browsing
8.1. Setting the encoding meta tag on save
8.2. Setting the default base directory
8.3. Merging file browser views
8.4. Backup files
8.5. Using multiple instances of a file
9. Customizing the user interface
10. Modifying file types
11. Modifying the files filters
12. Modifying the highlighting patterns
IX. Shortcuts available within Bluefish
1. General Shortcuts
2. HTML Shortcuts
3. Developing Bluefish
X. Debugging Bluefish
1. Using the Debugger
2. Filling a bug report
XI. Reference
1. Options in the Editor Tab
2. Options in the HTML Tab
3. Options in the Files Tab
4. Options in the User interface Tab
5. Options in the Images Tab
XII. Development guidelines
1. Indenting and formating style
2. Naming
3. Declaring procedures
4. Header files
5. New files
6. File reference
7. Patches
8. Translations
8.1. Introduction
8.2. PO files basics
8.3. Shortcut keys
8.4. How to contribute
9. Some tips
10. Making releases
11. Useful stuff
A. Credits
1. Bluefish developers
2. Bluefish package maintainers
3. Bluefish translators
4. Supporters to bluefish
B. Bluefish change history
C. Guidelines for Writing this Manual
1. Introduction to DocBook
2. Manual building requirements
3. Make HTML/PDF/PostScript Versions of the Bluefish manual
4. Conventions for Writing this Manual
4.1. The id Attribute
4.2. Using Screen shots
4.3. Referencing Bluefish interface elements
4.4. Using procedures
4.5. Using notes, tips, warnings
4.6. Using links
4.7. Others tags
4.8. Recommendation
4.9. Contact us
1. Preamble
3. How to Apply These Terms to Your New Programs

List of Figures

IV.1. Bluefish Editor Array
IV.2. List of open Documents
IV.3. Bluefish Main Menu
IV.4. Bluefish Main Tool Bar
IV.5. Bluefish HTML Tool Bar
IV.6. Bluefish Custom Tool Bar
IV.7. Bluefish Sidebar Notebook Tab
IV.8. Bluefish File Browser
IV.9. Bluefish Function Reference Browser
IV.10. Bluefish Bookmark Browser
IV.11. Bluefish Status Bar
IV.12. Bluefish View Menu
IV.13. Bluefish About Window
V.1. Bluefish File Menu
V.2. The File Browser Contextual Menu
V.3. Untitled Document Window
V.4. The File Name Dialog
V.5. The Directory Name Dialog
V.6. Bluefish Open File Dialog
V.7. Filtering Files with the Bluefish File Browser
V.8. Info on open File
V.9. Saving an untitled File
V.10. A modified Document in the Documents' List
V.11. Saving a File under a new Name
V.12. Moving a File to another Location
V.13. Closing a File with the Document Tab Icon
V.14. Closing a modified File
V.15. Closing all Files
V.16. Inserting a File
V.17. The Input Methods Contextual Menu
V.18. Writing in Japanese with Bluefish
V.19. Finding a Word in a Document, from Start to End
V.20. Unsuccessful Search Window
V.21. Highlighted Search Result in the Document Window
V.22. Setting the Cursor Location
V.23. Choosing a limited Search Method
V.24. Limited Search Result
V.25. Making the Search Case Sensitive
V.26. Case Sensitive Search Result
V.27. Finding overlapping Strings
V.28. An overlapping String retrieved with the Find Dialog
V.29. Retrieving recent Searches
V.30. The Replace Dialog
V.31. Changing letter Case when Replacing
V.32. The Replace Confirm Dialog
V.33. Opening an URL from the Web
V.34. A Style Sheet opened via the Open URL Menu
V.35. Using the Open Advanced Dialog
VI.1. Bluefish Go Menu
VI.2. Using the Goto Line Dialog
VI.3. The Bluefish Project Menu
VI.4. The Create Project Dialog
VI.5. Creating a New Project
VI.6. Entering Bluefish Project Filename
VI.7. Selecting a Bluefish Project
VI.8. Opening a Bluefish Project
VI.9. How Bookmarks are marked
VI.10. Bookmarks in the Side Panel
VI.11. Contextual Menu on Bookmark in the Side Panel
VI.12. Editing a Bookmark
VI.13. A named Bookmark
VI.14. The Contextual Menu on a Document in the Bookmark Tab
VI.15. Bookmarking with Posix Regular Expression
VI.16. Bookmarks with Posix Regular Expression
VI.17. Bookmarking Objective C Functions via the Find Menu
VI.18. Bookmarking PHP Functions via the Find Menu
VI.19. Nth Occurrence with Find Again
VI.20. Nth+1 Occurrence with Find Again
VI.21. Selecting a String for subsequent Search
VI.22. Finding a String from Selection
VI.23. The table before Transformation
VI.24. The table after Transformation
VII.1. Indenting Part of a Text
VII.2. Bluefish Spell Checker
VII.3. The Reference Browser Contextual Menu
VII.4. The Reference Browser Options Menu
VII.5. A Function Reference Dialog Window
VII.6. Info available for a Function
VII.7. The HTML Tags Menu
VII.8. The HTML Dialogs Menu
VII.9. An HTML Button with a three-dotted Tool Tip
VII.10. A simple HTML Tool Tip Button
VII.11. The Replace Special Menu
VII.12. The Insert Thumbnail Icon
VII.13. The Multi Thumbnail Icon
VII.14. The Insert Thumbnail Dialog
VII.15. The Multi Thumbnail Dialog
VII.16. The Table Icon in the HTML Tool Bar
VII.17. Adding an Element to the Quick Bar
VII.18. The added Element in the Quick Bar
VII.19. Adding a Pop Up Menu Element to the Quick Bar
VII.20. Removing an Element from the Quick Bar
VII.21. Moving an Element within the Quick Bar
VII.22. Accessing the Custom Menu
VII.23. The Custom Menu Editor
VII.24. Extract of the default Custom Menu Path
VII.25. The Custom Replace Dialog
VII.26. A new Custom Entry in the Menu Path List
VII.27. A new Menu in the Custom Menu Tool Bar
VII.28. A Block of selected Text before Activating the Menu
VII.29. A Block of Text after Activating the Menu
VII.30. The new DIV with Class Dialog
VII.31. The Block of Text after Entering the Value
VII.32. The HTML Page before the Transformation
VII.33. The HTML Page after the Transformation
VII.34. The Custom Menu Replace Dialog filled in
VII.35. The Add Title Dialog
VII.36. Bluefish External Menu
VII.37. The Browsers Panel in Preferences
VII.38. Selecting the Browser's Line to be Moved
VII.39. Dragging the Browser's Line
VII.40. Dragging the Browser's Line to the Bottom
VII.41. Utilities and Filters Panel in Preferences
VII.42. The tidy Output Box
VII.43. The Output Parsers Tab in Preferences Panel
VIII.1. Adding a Shortcut to a Menu Item
VIII.2. Turning Files and Folders Visibility ON
VIII.3. Bluefish with a customized Gtk Theme
VIII.4. The Editor Tab in Preferences
VIII.5. The Bookmarks Path Pop up Menu in Preferences
VIII.6. The HTML Tab in Preferences
VIII.7. The Author Meta Tag filled in on Save
VIII.8. Update of the Author Meta Tag on Save
VIII.9. The Files Preference Panel
VIII.10. Choosing an Action on Backup Failure
VIII.11. The User Interface Preference Panel
VIII.12. The HTML Pattern
VIII.13. The <html> Tags Pattern
VIII.14. The HTML Attributes Pattern
VIII.15. The HTML Attribute Contents Pattern
VIII.16. The PHP Block Pattern
VIII.17. The Comment (C++/single line) Pattern
VIII.18. Syntax Highlighting Example

List of Tables

IX.1. Shortcuts for all Document Types
IX.2. Shortcuts for HTML Markup
XI.1. Editor Tab Reference
XI.2. HTML Tab Reference
XI.3. HTML Tab Reference
XI.4. User interface Tab Reference
XI.5. Images Tab Reference

List of Examples

VI.1. Retrieving all sections in an xml book
VI.2. Retrieving all functions in an Objective C file
VI.3. Retrieving all functions in a PHP file
VI.4. Transforming a table into a definition list
VIII.1. Adding a file type
VIII.2. Adding a file filter

List of Procedures

I.1. Getting the source
II.1. Getting the new defaults after upgrading - First method
II.2. Getting the new defaults after upgrading - Second method
V.1. Writing in Japanese with Bluefish on a non-Japanese system
V.2. Searching from selection
VI.1. Creating a New Project
VII.1. Generating a photos album with multi thumbnails
VII.2. Adding a custom menu based on custom dialog
VII.3. Adding a custom menu based on replace dialog
VII.4. Changing the order of browsers items
VII.5. Customizing an existent browser
VII.6. Adding a new browser
VII.7. Adding a Commands menu item
VII.8. Adding an Outputbox menu item
X.1. Running bluefish under gdb
C.1. Getting the Bluefish manual source files
C.2. Installing DocBook and DocBook XSL
C.3. Installing the xslt processors and parsers